使Delphi 6.0 支持 Apache 2.0

页面导航:首页 > 软件编程 > Delphi > 使Delphi 6.0 支持 Apache 2.0

使Delphi 6.0 支持 Apache 2.0

来源: 作者: 时间:2016-02-05 11:47 【

我们都知道,Bolrand 从Delphi 6.0 以后开始支持Apache web 服务器,而Apache 以其出色的性能及安全性是很多人青睐。Apache 现在最新的版本为2.0.43。虽然Borland 今年新出的Delphi 7 开始支持Apach

 

我们都知道,Bolrand Delphi 6.0 以后开始支持Apache web 服务器,而Apache 以其出色的性能及安全性是很多人青睐。Apache 现在最新的版本为2.0.43。虽然Borland 今年新出的Delphi 7 开始支持Apache 2.0 版本,但是Delphi 6 只支持Apache 1.x 版本,而Delphi 7 发行的版本也只支持到Apache 2.0.39 版,对Apache 2.0.40 以后的版本无法支持,本文给出了让Delphi 6Delphi7 支持最新的Apache 2.0.43 的方法。

首先让我们对Delphi 7 进行改造,Delphi 7.0 不支持 Apache 2.0.40 以后的版本的原因是Apache 2.0.40 以后版本修改了接口文件,因此要对Delphi 7.0 对应的接口文件进行修改,

具体的修改文件为: HTTPD2.pas,修改内容为:

  • 打开 HTTPD2.pas (在c: Program Filesorland7source Internet下)
  • 修改一下常数:

·                ·               

Tags:

文章评论


<