Ubuntu13.04下源码安装Rapidsvn

页面导航:首页 > 操作系统 > LINUX > Ubuntu13.04下源码安装Rapidsvn

Ubuntu13.04下源码安装Rapidsvn

来源: 作者: 时间:2016-08-18 10:29 【

Ubuntu13.04下源码安装Rapidsvn默认安装目录为:/usr/local准备工作:1.安装 apr-1.4.6.tar.gztar -zxvf apr-1.4.6.tar.gzcd apr-1.4.6./configure --prefix=/usr/local/apr-1.4.6makemake install2.安装 ...
Ubuntu13.04下源码安装Rapidsvn
 
默认安装目录为:/usr/local
 
准备工作:
 
1.安装 apr-1.4.6.tar.gz 
 
tar -zxvf apr-1.4.6.tar.gz 
 
cd apr-1.4.6
 
./configure --prefix=/usr/local/apr-1.4.6
 
make
 
make install
 
2.安装 apr-util-1.5.1.tar.gz
 
cd apr-util-1.5.1
 
./configure --prefix=/usr/local/apr-util-1.5.1 --with-apr=/usr/local/apr-1.4.6/
 
 
make
 
make install
 
3.安装 subversion-1.7.7.tar.gz
 
tar -zvxf subversion-1.7.7.tar.gz
 
cd subversion-1.7.7
 
./configure --prefix=/usr/local/subversion-1.7.7 --with-apr=/usr/local/apr-1.4.6/ --with-apr-util=/usr/local/apr-util-1.5.1/
 
这时候会报错,因为subversion需要sqlite支持,到http://www.sqlite.org/最新版包,解压后将
 
sqlite3.c文件复制到subversion-1.7.7/sqlite-amalgamation/下,然后重新编译
 
继续报错,缺少zlib,安装zlib
 
tar -zxvf zlib-1.2.8.tar.gz
 
cd zlib-1.2.8
 
./configure --prefix=/usr/local/zlib-1.2.8
 
make
 
make install
 
到subversion-1.7.7目录
 
./configure --prefix=/usr/local/subversion-1.7.7 --with-apr=/usr/local/apr-1.4.6/ --with-apr-util=/usr/local/apr-util-1.5.1/ --with-zlib=/usr/local/zlib-1.2.8/
 
make
make install
 
4.安装 wxWidgets-2.8.12.tar.gz
 
tar -zvxf wxWidgets-2.8.12.tar.gz
 
cd wxWidgets-2.8.12
 
./configure --prefix=/usr/local/wxWidgets-2.8.12
 
这时报错,提示缺少gtk
 
apt-get install libgtk2.0-dev
 
继续编译
 
./configure --prefix=/usr/local/wxWidgets-2.8.12
 
make
 
make install
 
准备工作完毕;
 
然后跳到rapidsvn-0.12.1目录,进行rapidsvn的编译
 
./configure --prefix=/usr/local/rapidsvn-0.12.1 --with-apr-config=/usr/local/apr-1.4.6/bin/apr-1-config  --with-apu-config=/usr/local/apr-util-1.5.1/bin/apu-1-config --with-svn-include=/usr/local/subversion-1.7.7/include/ --with-svn-lib=/usr/local/subversion-1.7.7/lib/ --with-wx-config=/usr/local/wxWidgets-2.8.12/bin/wx-config
 
make
 
make install
 
安装完毕
 
cd /usr/local/rapidsvn-0.12.1/bin
 
运行程序
 
./rapidsvn
 
提示缺少一系列库文件(lib)
 
cp  /usr/local/wxWidgets-2.8.12/lib/libwx_gtk2_adv-2.8.so.0 /usr/lib/libwx_gtk2_adv-2.8.so.0
 
cp  /usr/local/wxWidgets-2.8.12/lib/libwx_gtk2_core-2.8.so.0 /usr/lib/libwx_gtk2_core-2.8.so.0
 
cp  /usr/local/wxWidgets-2.8.12/lib/libwx_gtk2_base-2.8.so.0 /usr/lib/libwx_gtk2_base-2.8.so.0
 
cp  /usr/local/wxWidgets-2.8.12/lib/libwx_base-2.8.so.0 /usr/lib/libwx_base-2.8.so.0
 
运行程序
 
./rapidsvn
 
OK
 
安装工作到此全部结束!
 
Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<