这篇文章主要介绍了详解yum命令之–showduplicates的使用方法,适用于RedHat系的Linux,需要的朋友可以参考下

yum有很多参数和插件可以用,这里我介绍下yum  --showduplicates命令的使用方法,这个参数对于我们来说十分有用。尤其是当你遇到版本不匹配兼容、软件依赖问题,就可以使用这个命令,找到你要 的软件版本。
假设这里需要为php找到一个特定版本的pcre,输入:

   

复制代码
代码如下:
#yum search --showduplicates pcre

则会用pcre这个关键词去yum 源  中搜索匹配的软件包

输出:

   

复制代码
代码如下:
Loaded plugins: fastestmirror, versionlock</p> <p> Loading mirror speeds from cached hostfile</p> <p> * base: mirrors.usc.edu</p> <p> * extras: mirror.web-ster.com</p> <p> * updates: mirror.hmc.edu</p> <p> Reading version lock configuration</p> <p> =========================== Matched: pcre ======================</p> <p> pcre-6.6-9.el5.i386 : Perl-compatible regular expression library</p> <p> pcre-6.6-9.el5.i386 : Perl-compatible regular expression library</p> <p> pcre-devel-6.6-9.el5.i386 : Development files for pcre

根据输出的信息,找到自己要的版本的完整名字,然后用yum安装即可

 

当然,这个用  yum search –showduplicates ,输出的包太多,如果不是很明确目标的话,根本无法确定哪个包是我们可以用的。所以,可以用下面命令:

   

复制代码
代码如下:
# yum --showduplicates list php-gd

输出:

  

复制代码
代码如下:
Loaded plugins: fastestmirror, versionlock</p> <p> Loading mirror speeds from cached hostfile</p> <p> * base: mirrors.usc.edu</p> <p> * extras: mirror.web-ster.com</p> <p> * updates: mirror.hmc.edu</p> <p> Reading version lock configuration</p> <p> Available Packages //可用的包</p> <p> php-gd.i386 5.1.6-40.el5_9 base</p> <p> php-gd.i386 5.1.6-43.el5_10 update

 

下面对比下加available和不加的区别,这里查看可用的pcre,先输入:

   

复制代码
代码如下:
# yum --showduplicates list available pcre //查看可用的pcre

输出为:

  

复制代码
代码如下:
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
* base: mirrors.usc.edu
* extras: mirror.keystealth.org
* updates: mirror.hmc.edu
Reading version lock configuration
Available Packages
pcre.i386 6.6-9.el5 base

 

在去掉available,输入:

   

复制代码
代码如下:
# yum --showduplicates list pcre

 

输出:

   

复制代码
代码如下:
Loaded plugins: fastestmirror, versionlock</p> <p> Loading mirror speeds from cached hostfile</p> <p> * base: mirrors.usc.edu</p> <p> * extras: mirror.web-ster.com</p> <p> * updates: mirror.hmc.edu</p> <p> Reading version lock configuration</p> <p> Installed Packages</p> <p> pcre.i386 6.6-9.el5 installed</p> <p> Available Packages</p> <p> pcre.i386 6.6-9.el5 base

 

是不是多了installed   packages 行,不过如果你是源码安装,而非rpm或yum安装的 ,则不会显示这行的。


上面的命令,可以直接用

  

复制代码
代码如下:
#yum list 软件名

代替使用。