linux系统中QQ的使用和配置

页面导航:首页 > 操作系统 > RedHat/Centos > linux系统中QQ的使用和配置

linux系统中QQ的使用和配置

来源: 作者: 时间:2015-12-18 14:17 【

很多朋友的机器上都安装了Linux,并且想在Linux环境中使用QQ。下面就将本人在Red Hat 9.0上配置QQ的成功经验共享出来。选择QQ软件腾迅公司并没有推出专门应用于Linux下的QQ软件,但是已经
很多朋友的机器上都安装了Linux,并且想在Linux环境中使用QQ。下面就将本人在Red Hat 9.0上配置QQ的成功经验共享出来。 选择QQ软件 腾迅公司并没有推出专门应用于Linux下的QQ软件,但是已经有很多自由软件或插件支持在Linux下使用QQ。这些软件都可以在Interne

很多朋友的机器上都了Linux,并且想在Linux环境中使用QQ。下面就将本人在Red Hat 9.0上配置QQ的成功经验共享出来。

选择QQ软件

腾迅公司并没有推出专门应用于Linux下的QQ软件,但是已经有很多自由软件或插件支持在Linux下使用QQ。这些软件都可以在Internet上获得,常用的有Gaim+OpenQ、Gaim+libqq和LumaQQ等。以下链接可以分别获得这些软件:

Gaim网址为http://gaim.sourceforge.net/downloads.php

Libqq网址为http://zd.linux.com.cn。

OpenQ网址为http://openq.linuxsir.org/cgi-bin/wiki/moin.cgi/_cf_c2_d4_d8。

LumaQQ网址为http://linad.8866.org/share/Linux_Software/%bf%cd%bb%a7%b6%cb/lumaqq-0.1b.tar.bz。

Gaim+libqq和Gaim+OpenQ都是在Gaim中添加QQ插件,所以必须注意Gaim与QQ插件的版本对应关系。

Gaim与libqq的版本对应关系举例如下:

◆ libqq-0.0.1-0.48.so适用于Gaim 0.48、0.49;

◆ libqq-0.0.1-0.50.so适用于Gaim 0.50;

◆ libqq-0.0.1-0.51.so适用于Gaim 0.51、0.52;

◆ libqq-Gaim-0.48-qq.patch适用于Gaim 0.48、0.49 0.50;

◆ libqq-Gaim-0.51-qq.patch适用于Gaim 0.51、0.52。

Gaim与OpenQ的对应关系请参看http://openq.linuxsir.org/cgi-bin/wiki/moin.cgi/_cf_c2_d4_d8。
QQ

在Linux上软件有Tarball和RPM两种方式,Tarball是类Unix操作中常见的方式;RPM(Red Hat Package Manage)是Red Hat公司推出的包管理方式,这是一种非常不错的管理方式,但是有时候会遇到一些依赖关系的问题。

1.用Tarball方式

以一个包含了libqq插件的Gaim包gaim-cvs-0218-qq-0.2.5.tar.gz为例,使用下列命令(不推荐使用root权限):

 

$ tar zxvf gaim-cvs-0218-qq-0.2.5.tar.gz
$ cd gaim-cvs-0218-qq-0.2.5
$ ./configure --prefix=/home/foo/bin/local/gaim && make &&make install 
$ cd ~/bin
$ ln -s /home/foo/bin/local/gaim/bin/gaim gaim

“./configure--prefix=/home/foo/bin/local/gaim”指定了软件的目录是/home/foo/bin/local/gaim。

“&&”的作用是前一个命令成功执行后才执行后面的命令。这与使用“;”是有区别的,“;”的作用是分别执行两边的命令,不论前一个命令是否执行成功。

注意,如果中已经了Gaim,就需要编辑.bash_profile文件,修改“PATH”为“PATH=$HOME/bin:$PATH”,然后执行source .bash_profile命令。

如果Gaim安装包中没有包含libqq插件,可以用下列命令libqq:

 

$ gunzip libqq-0.0.3-ft-0.58-gcc296.so.gz
$ su -c "cp libqq-0.0.3-ft-0.58-gcc296.so /usr/lib/gaim"

2.用RPM方式

RPM安装方式会按照制作RPM包时的规定软件,并且需要使用root权限。

Gaim的软件包gaim-0.58-2.i386.rpm和libqq插件libqq-0.0.3-ft-0.58-gcc296.so.gz,执行下列命令:

 

# rpm -qa|grep gaim
# rpm -e gaim
# rpm -ivh gaim-0.58-2.i386.rpm
# gunzip libqq-0.0.3-ft-0.58-gcc296.so.gz
# cp libqq-0.0.3-ft-0.58-gcc296.so /usr/lib/gaim

OpenQ也是Gaim的QQ插件,与libqq类似。

3.LumaQQ的

其实,LumaQQ是不需要的,只要把它的软件包解压缩,在它的启动脚本中修改Java环境变量后即可运行。使用LumaQQ可能会遇到一个问题:如果先打开LumaQQ,那么XMMS将不会发出声音;反之,LumaQQ将不会有提示音。这是由于Linux对声卡的独占式使用造成的,可以通过更改声卡驱动,使用ALSA管理声卡来此问题。

在桌面创建快捷方式

1.GNOME桌面

在桌面上单击鼠标右键,选择“创建快速启动器”。分别填入需要的信息(使用Gaim搭配插件的QQ时,注意Gaim的路径),然后单击图标按钮,选择喜欢的图标。默认情况下图标都存放在/usr/share/pixmaps目录中,可以更改路径以得到更多的选择。

2.KDE桌面

在桌面上单击鼠标右键,选择“新建→应用程序链接”。填写快捷方式的名字,并且选择图标,然后在“执行”标签的命令栏里填入命令(全路径)。

在任务栏创建快捷方式

1.GNOME桌面

在任务栏上单击鼠标右键,选择“add to panel→launcher”,创建图标,并指定命令;或者选择“launcher from menu”,从选单中选择图标。

2.KDE桌面

在任务栏上单击鼠标右键,选择“面板选单→添加→特殊按钮→非KDE应用程序”,填写命令后单击“确定”按钮即可。

小结

在Linux中使用QQ并非难事,很多朋友失败是因为缺乏细心与耐心。只要仔细注意在过程中提示的信息,认真考察环境,详细阅读README等文档,就一定可以让Linux和QQ这两只企鹅协同工作,为生活和工作带来便利。
 

Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<