Linux系统下编译安装飞鸽传书g2ipmsg

页面导航:首页 > 操作系统 > RedHat/Centos > Linux系统下编译安装飞鸽传书g2ipmsg

Linux系统下编译安装飞鸽传书g2ipmsg

来源: 作者: 时间:2015-12-18 14:17 【

系统Mandriva 2008,飞鸽版本为0.9.5。首先需要另外一些包,系统有些还没有,只能重新装,包据libgnomeui-2, gtk+-2, glib-2,libpanel-applet-2等,使用./configure会有相应的提示,把缺少的装上就行了
系统Mandriva 2008,飞鸽版本为0.9.5。   首先需要另外一些包,系统有些还没有,只能重新装,包据libgnomeui-2, gtk+-2, glib-2,libpanel-applet-2等,使用./configure会有相应的提示,把缺少的装上就行了,如libgnomeui2-devel-2.20.0-2mdv2008.0。  

Mandriva 2008,飞鸽版本为0.9.5。

 

首先需要另外一些包,有些还没有,只能重新装,包据libgnomeui-2, gtk+-2, glib-2,libpanel-applet-2等,使用./configure会有相应的提示,把缺少的装上就行了,如libgnomeui2-devel-2.20.0-2mdv2008.0。

 

准备工作完成之后,接下来

./configure

make

make install

 

然后就可以在/usr/local/bin中找到g2ipmsg程序了,运行它就可以了。但是,这样它不支持中文。再看看README文件,说是支持中文的话要另加参数,无奈,只能重新。

 

make uninstall //作者做事倒也仔细,把这个功能也做全了。

 

按README文件是:

./configure --enable-systray --with-ext-charcode=CP936

 

即把编码指定为CP936。好,就按他说的办。这样再make&&make install之后,运行程序却仍不能显示中文,不知是被作者忽悠了还是RP有问题。

 

接下来是一阵无奈的Google和百度,按网上一些介绍的试了个遍,仍不见效。最终的是在源码中修改一点点东西。把该程序src目录的codeset.c中的

 

#define IPMSG_PROTO_CODE IPMSG_EXTERNAL_CHARCODE

这一行改为

#define IPMSG_PROTO_CODE “CP936”

#define IPMSG_PROTO_CODE "UTF-8" //(如果编码不是UTF-8可能会有问题)

 

就可以了。

 

至此已完成了Linux下飞鸽传书的,按理说就可以跟Windows下的飞鸽直接交流了。该版本据说只能传单个文件,不能传文件夹。

Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<