问题描述:Linux下直接双击rpm安装包,会出现错误提示: Failed to install! You don't have the necessary privileges to install local packages 这是由于安全的缘故。 解决方法:在终端/命令提示符下,用root用户进行安装,安装新文件用安装命令,

问题描述:Linux下直接双击rpm安装包,会出现错误提示:

Failed to install!
You don't have the necessary privileges to install local packages

这是由于安全的缘故。

:在终端/命令提示符下,用root用户进行,新文件用命令,如果出现冲突-conflict的情况,那么可能是已经存在了,需要升级软件用升级命令。

1.命令
rpm -ivh rpm文件名

参数解释
-i
-h 解压rpm的时候打印50个斜条 (#)
-v 显示详细信息

2.升级命令
rpm -Uvh rpm文件名

参数解释
-U 升级
-h 解压rpm的时候打印50个斜条 (#)
-v 显示详细信息