ubuntu 12.04安装最新版本的nmap出现的几个问题分析

页面导航:首页 > 操作系统 > Ubuntu/Debian > ubuntu 12.04安装最新版本的nmap出现的几个问题分析

ubuntu 12.04安装最新版本的nmap出现的几个问题分析

来源: 作者: 时间:2015-12-04 17:14 【

这篇文章主要介绍了ubuntu 12.04安装最新版本的nmap出现的几个问题分析,需要的朋友可以参考下
这篇文章主要介绍了ubuntu 12.04安装最新版本的nmap出现的几个问题分析,需要的朋友可以参考下
NMAP(网络映射器)是一支多平台且超多功能的网路管理工具程式,系统管理人员可以用Nmap的程式来对电脑做很多的事,包括侦测,扫瞄,监测和撷取资料等(同样的,骇客也可以用Nmap的来做这些事哩!“),但是,就是因为Nmap的的功能强大,所以,相对的,要记住和学习的Nmap的参数和选项也就跟着多起来了,不过,阿舍今天还没有要讲怎么用Nmap的,因为,阿舍光要安装Nmap的时,就遇到一个小小的问题了哩!

电影中常会用到的Nmap的画面哩!

阿舍听说问题Ubuntu的PPA就有的Nmap可以安装,所以,就直接打了下面的这一行指令来安装Nmap的结果,是有安装起来,不过,等阿舍执行的Nmap的时候,就发现问题Ubuntu的PPA放的不是最新的Nmap的6哩!因此,阿舍就迅速的把它给移除了哩!

sudo apt-get install nmap

于是阿舍就到的Nmap的官方网站来查了一下,很不幸的,在Nmap的的官网上是没有提供给Ubuntu的或Debian的用的deb文件安装档哩!阿舍找了一下,在下载的网页上只有看到给RPM的安装档而已,不过,还好,RPM安装档也是可以拿来给Ubuntu的用的,只是,在用RPM RPM档就可以了。

sudo apt-get install alien

安装好外来程式之后,请到Nmap的官网的下戴网页来下载的Nmap的RPM安装档,然后,在下戴完成后,请用下面的指令来把下载来的的Nmap的RPM安装档案转换成DEB档并同时进行安装(使用 - 选项的话,安装完成后,不会留下转换好的DEB安装档)。

sudo alien -i nmap-6.4-1.i386.rpm

不过,在用上面的指令安装完成后,NMAP还是不能用的,如果安装完成后就马上执行的Nmap RPM内的Nmap的版本是有包含更新功能的,所以,Nmap的会需要用到一个叫做「libsvn_client」的程式库来用哩!

nmap: error while loading shared libraries: libsvn_client-1.so.0: cannot open shared object file: No such file or directory

而这个「libsvn_client」的程式库要安装SVN程式才会有的,所以,请执行下面的指令来安装SVN软体,安装完成后,因为新版的SVN程式是带“为之1.so.0」这个版本,而不是Nmap的

sudo apt-get install subversion
sudo ln -s /usr/lib/i386-linux-gnu/libsvn_client-1.so.1 /usr/lib/libsvn_client-1.so.0

如果是64位元的Ubuntu的版本的话,上一行指令请更改如下。

sudo ln -s /usr/lib/x86_64-linux-gnu/libsvn_client-1.so.1 /usr/lib/libsvn_client-1.so.0

上面的指令都完成后,应该就可以顺利使用最新版的Nmap的了哩!
Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<