这些受经济危机的影响,各个公司风云变换,就连我待部门也不例外,心头总是感到很沉重的危机感。偶然瞥见书架上一年前买的《Programming Ruby》,终于决定再次把它拿出来,继续学习,也好为以后的“不测”做个准备。 前几天看到同事用Ubuntu,感觉挺有意思,于是
这些受经济危机的影响,各个公司风云变换,就连我待部门也不例外,心头总是感到很沉重的危机感。偶然瞥见书架上一年前买的《Programming Ruby》,终于决定再次把它拿出来,继续学习,也好为以后的“不测”做个准备。
前几天看到同事用Ubuntu,感觉挺有意思,于是就准备也学习一下,就确定了在Ubuntu下学习Ruby的开发,以及以后的ROR开发。当然首要的任务还是安装Ruby的运行环境。
打开Terminal,输入:ruby -v,提示命令不可用,所以需要安装Ruby的运行环境。
运行:sudo apt-get install ruby,提示输入密码,可是输入密码后,提示没有权限,不知道怎么回事儿。当然是就运行了一下:sudo passwd root,为root账户设置了密码。而后,再次运行安装命令 sudo apt-get install ruby,输入密码(当前账户的密码),竟然开始下载和安装了。
安装完成后,运行:ruby -v,提示当前安装的版本是1.8。不过我从网站看到最新版本是1.9,但是不知道是否这里也有。于是就用了:sudo apt-cache search ruby,在出现的列表中发现了ruby1.9的身影,在尝试: sudo apt-get update ruby 升级没有作用之后,也由于1.8是稳定版本,就不再更换了。
书上提到了irb是一个很好用的ruby交互环境,而且在开发过程中要不断查阅文档,于是就使用:
sudo apt-get install irb
sudo apt-get install ri
安装了irb环境和ri文档查阅工具。
至此,简单的Ruby开发环境配置完毕。