Freebsd 下运行 QQ For Linux 的方法

页面导航:首页 > 操作系统 > Unix/BSD > Freebsd 下运行 QQ For Linux 的方法

Freebsd 下运行 QQ For Linux 的方法

来源: 作者: 时间:2015-11-30 10:41 【

在Freebsd 下運行 QQ For Linux 的方法必須滿足:1 FreeBSD 版本為6.0 以上,FreeBSD 5 未測試2 系統安裝的 linux_base 不能是 fc4 版的,即不能是linux_base-fc-4,其它的均可(linux_base-fc6linux_base-f7 linux_
在Freebsd 下運行 QQ For Linux 的方法 必須滿足: 1 FreeBSD 版本為6.0 以上,FreeBSD 5 未測試 2 系統安裝的 linux_base 不能是 fc4 版的,即不能是linux_base-fc-4,其它的均可(linux_base-fc6  linux_base-f7 linux_base-f8 均可) 方法

在Freebsd 下運行 QQ For Linux 的

必須滿足:

1 FreeBSD 版本為6.0 以上,FreeBSD 5 未測試
2 系統安裝的 linux_base 不能是 fc4 版的,即不能是linux_base-fc-4,其它的均可(linux_base-fc6  linux_base-f7 linux_base-f8 均可)



1 在 /boot/loader.conf 中加入
   
    linux_load="YES"

當然如果有了修改即可.


2 在 /etc/sysctl.conf 中加入

   compat.linux.osrelease=2.6.16

當然如果有了修改即可, 也不一定要 2.6.16 只要 2.6.8 或以上即可。

3 在 /etc/rc.conf 中加入

   linux_enable=”YES”

當然如果有了修改即可。

4 安裝一個你喜歡的 linux_base (linux_base-fc6  linux_base-f7 linux_base-f8 均可,不一定要最新的linux_base-f8 )
可以用  pkg_add -r 或用 ports 安裝。
它們在
/usr/ports/emulators/linux_base-fc6
/usr/ports/emulators/linux_base-f7
/usr/ports/emulators/linux_base-f8

5 挂 linux 的文件系統,在 /etc/fstab 中加入

  linprocfs /compat/linux/porc linprocfs rw 0 0

當然如果有了修改即可。

6 安裝 linux-expat
/usr/ports/textproc/linux-expat

7 安裝 linux-fontconfig
/usr/ports/x11-fonts/linux-fontconfig

8 安裝 linux-xorg-libs
/usr/ports/x11/linux-xorg-libs

9 下載本人製作的QQng-Freebsd.tar.bz2 ,將其解壓到 /compat/linux/opt
bzcat QQng-Freebsd.tar.bz2 | gtar -xvf - -C /compat/linux/opt

10 到 tx 官方下載 QQ For Linux 的 tar.gz 版,將裏面的文件 copy 到 /compat/linux/opt/QQ/bin

11 運行 /compat/linux/opt/QQ/run-QQ.sh 即可運行

12 如果不能輸入中文輸入以下命令
/compat/linux/usr/bin/localedef -i zh_CN -f UTF-8 zh_CN
/compat/linux/usr/bin/localedef -i zh_CN -f GB2312 zh_CN
/compat/linux/usr/bin/localedef -i zh_CN -f GBK zh_CN
/compat/linux/usr/bin/localedef -i zh_CN -f GBK18030 zh_CN


歡迎轉載 轉載請註明作者
作者:Power_By_RTL QQ:3942082328
注意轉載請勿修改包裏的内容及去掉作者信息,否則禁止轉載

附上FreeBSD 效果图
 

下载:

Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<