由于工程版本过久,安装了老的Android Studio版本,随便建Activity试了一下环境出现了两个问题。

问题描述:

Android Studio新建活动,什么都没做,报错

  1. 添加布局之后Preview无法显示,报错为Render Problem。
  2. Failed to resolve: com.android.support:appcompat-v7:27.+

解决方法:

按照网上其他博客的说法是API版本过高导致无法运行,自己也以为是这个原因,但是修改了低版本的API仍然无法解决。
后来在查第二个问题的时候发现这两个问题都是由版本不匹配引起的。
在module下的gradle文件中定义了compileSdkVersion、buildToolsVersion、targetSdkVersion的版本号,和依赖中appcompat的版本号:compile 'com.android.support:appcompat-v7:27.+'

  1. compileSdkVersion是SDK Manager的API Level
  2. buildToolsVersion是AndroidSDK/build-tools目录下的工具版本号
  3. targetSdkVersion是目标版本号,需要和其他三个的大版本号设置相同
  4. AndroidSDK/extras/android/m2repository/com/android/support/appcompat-v7目录下的依赖包版本号

需要使build.gradle下相关工具的版本统一,下载了相关的版本之后,修改gradle对应内容,能够显示界面,没有出现报错。

本文固定链接: http://www.js-code.com/android/android_55400.html