脚本宝典收集整理的这篇文章主要介绍了

Ubuntu 15.04开发Ionic之环境配置

脚本宝典小编觉得挺不错的,现在分享给大家,也给大家做个参考,希望能帮助你少写一行代码,多一份安全和惬意。

Ubuntu 15.04开发Ionic之环境配置

@(环境配置)


环境配置

  • nodejs :Cordova安装依赖nodejs(略)

  • java sdk :Ionic build需要java环境;

  • android sdk :Ionic build需要android环境;

  • ionic

1.java sdk安装配置

1.Installing default JRE/JDK

sudo apt-get update
sudo apt-get install default-jre
sudo apt-get install default-jdk

2.Installing Oracle JDK (选择安装版本)

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update

sudo apt-get install oracle-java6-installer #Oracle JDK 6(旧版本)
sudo apt-get install oracle-java7-installer #Oracle JDK 7(较新的稳定版本) 建议选7
sudo apt-get install oracle-java8-installer #Oracle JDK 8(最新预览版本)

3.配置

sudo update-alternatives --config java
//出现 直接回车选择默认值
* 0 /usr/lib/jvm/java-7-oracle/jre/bin/java 1072 自动模式
1 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 手动模式
2 /usr/lib/jvm/java-7-oracle/jre/bin/java 1072 手动模式
sudo update-alternatives --config javac //同上操作

4.配置 JAVA_HOME 环境

sudo update-alternatives --config java //查看配置路径 path为"/usr/lib/jvm/java-7-oracle"
sudo vim /etc/environment
//在文件最后加上保存退出
JAVA_HOME="/usr/lib/jvm/java-7-oracle"
//最后是配置生效
source /etc/environment
java -version //查看是否配置成功

2.android sdk安装配置

1.在/opt下打开终端 (需要翻墙下载,速度不快)

wget http://dl.google.com/android/android-sdk_r23.0.2-linux.tgz -O android-sdk.tgz

完成后

mv "android-sdk-linux" "android-sdk"
chown root:root "android-sdk" -R
chmod 777 "android-sdk" -R

2.打开Android SDK Manager(download the SDK platform tools)

./opt/android-skd/tools/android

默认下载列表中的Tools API(下载了一天,网络不给力的后果)
Ubuntu 15.04开发Ionic之环境配置-脚本宝典
下载完成后 编辑 ~/.bashrc 加入Android SDK tools path

vim ~/.bashrc

在最后加入

export PATH=${PATH}:/opt/android-sdk/tools
export PATH=${PATH}:/opt/android-sdk/platform-tools

创建一个Android Virtual Device

android avd

Ubuntu 15.04开发Ionic之环境配置-脚本宝典
enter image description here

sudo vim /etc/environment
//在文件最后加上保存退出
ANDROID_HOME="/opt/android-sdk"
source /etc/environment

3.ionic

intall cordova && ionic 参考文档

npm install -g cordova ionic

Create the project cd /home/ubuntu/

ionic start myApp tabs

Configure Platforms

ionic platform add android
ionic build android

build 过程中错误解决方法

[Error: Please install Android target: "android-22".
Hint: Open the SDK manager by running: /opt/android-sdk/tools/android
You will require:
1. "SDK Platform" for android-22
2. "Android SDK Platform-tools (latest)
3. "Android SDK Build-tools" (latest)]

cd到myApp修改下面目录中的target=android-22为target=android-23
<uses-sdk android_minSdkVersion="16" android_targetSdkVersion="23" />
原因为执行Android SDK Manager 下载tools时最新版本为22

  • myApp/platforms/android/project.properties

  • myApp/platforms/android/CordovaLib/project.properties

  • myApp/platforms/android/AndroidManifest.xml

bulid 完成后apk 生成目录
/home//ubuntu/myApp/platforms/android/build/outputs/apk/android-debug.apk

参考链接

总结

以上是脚本宝典为你收集整理的

Ubuntu 15.04开发Ionic之环境配置

全部内容,希望文章能够帮你解决

Ubuntu 15.04开发Ionic之环境配置

所遇到的程序开发问题,欢迎加入QQ群277859234一起讨论学习。如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典网站推荐给程序员好友。 本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。

80%的人都看过