Discuz! X2.0 以后的版本都会对主题或插件做一个正版验证,如果是从别人那里买的盗版主题或插件的话,安装时会出现:对不起,您安装的不是正版应用,安装程序无法继续执行的字样。Forece 最近在淘宝上买了一套 Discuz X3.1 的插件,安装的时候就出现了这个问题。在网上搜索了一下。发现还挺好解决的。

找到以下文件:

复制代码

代码如下:


/source/function/function_cloudaddons.php


搜索代码:(大概在191行左右)



复制代码

代码如下:


cpmsg('cloudaddons_genuine_message', '', 'error', array('addonid' => $addonid));


将这行注释掉就可以了,注释后的代码如下:



复制代码

代码如下:


/*
cpmsg('cloudaddons_genuine_message', '', 'error', array('addonid' => $addonid));
*/