HTML5 声明兼容IE的写法

当前位置 : 首页 > 网页制作 > html5 > HTML5 声明兼容IE的写法

HTML5 声明兼容IE的写法

来源: 作者: 时间:2015-10-29 10:06
无意中看到百度的页面代码,想到了一种声明写法,需要的朋友可以参考下。
无意中看到百度的页面代码,想到了一种声明写法,需要的朋友可以参考下。
<!DOCTYPE html>是HTML5的声明,主流的游览器中只有IE8及以下版本不支持,这样IE会进入Quirks模式。但之后的声明可以强制指定IE的呈现模式,所以<!DOCTYPE html>声明对IE就无影响。

HTML5并没有XHTML那么严格,对于一般的xhtml页面,基本都不通完全通过W3C验证标准,而改为HTML5声明后基本都能过。


复制代码
代码如下:

<!DOCTYPE html>
<!–[if IE]>
<meta http-equiv=”X-UA-Compatible” content=”IE=8″ />
<![endif]–>
<!–[if IE 7]>
<meta http-equiv=”X-UA-Compatible” content=”IE=7″ />
<![endif]–>
<!–[if IE 6]>
<meta http-equiv=”X-UA-Compatible” content=”IE=6″ />
<![endif]–>

关于X-UA-Compatible
目前绝大多数网站都用

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" >

来作为IE8的兼容方法,虽然微软将IE向标准迈进了一大步,而事实上IE8还存在一系列渲染的奇怪现象是不争的事实。
谁让IE6那么多呢,或许2014年以后我们可以有更多的时间去关心IE8,而不是IE6或者IE7。
在X-UA-Compatible中可用的方法有:

复制代码
代码如下:

<meta http-equiv="X-UA-Compatible" content="IE=5" >
<meta http-equiv="X-UA-Compatible" content="IE=7" >
<meta http-equiv="X-UA-Compatible" content="IE=8" >
<meta http-equiv="X-UA-Compatible" content="IE=edge" >
[html]
其中最后一行是永远以最新的IE版本模式来显示网页的。
另外加上
[code]
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" >
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" >

而使用,Emulate模式后则更重视<!DOCTYPE>

所以目前来说,云下载还是推荐以下

复制代码
代码如下:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" >

为首选。
Tag:
网友评论

<