脚本宝典收集整理的这篇文章主要介绍了

第一次vue单页面应用ios低版本爬坑总结

脚本宝典小编觉得挺不错的,现在分享给大家,也给大家做个参考,希望能帮助你少写一行代码,多一份安全和惬意。

1.vue打包后iphone 5c ios10.3.3打开报错,调试时无错误. 求解决办法
问题链接

解决办法 webpack.prod.conf.js 配置

const UglifyJsPlugin = require('uglifyjs-webpack-plugin')
new UglifyJsPlugin({
  uglifyOptions: {
    compress: {
      warnings: false
    },
    mangle: {
      safari10: true
    }
  },
  sourceMap: config.build.productionSourceMap,
  parallel: true
})

2.出现"SyntaxError: Use of const in strict mode."的问题
问题链接
解决办法

通过降级webpack-dev-server到2.7.1版本 - 测试通过
使用babel-loader时,在非生产环境配置中,额外指定对node_modules/webpack-dev-server/client/index.js脚本的转换 - 测试通过
当然可能会是别的什么插件出现这种问题,解决办法同第2条.

3.iOS8.1 Safari 报错 SyntaxError: Unexpected keyword 'const'.
解决办法

第一种情况: 同问题2解决办法
第二种情况: 第一种情况不匹配,那可能是因为引用了某些插件,比如说 swiper 4.0

4.ios低版本 swiper打包后报 class 关键字错误解决办法
问题链接
当我发现引用低版本swiper后终于解决了问题3的报错,然鹅又有一个新的错误等着我.
解决办法

外部引用swiper

5.not a function
解决办法

 全局es6函数写法改es5

总结

以上是脚本宝典为你收集整理的

第一次vue单页面应用ios低版本爬坑总结

全部内容,希望文章能够帮你解决

第一次vue单页面应用ios低版本爬坑总结

所遇到的程序开发问题,欢迎加入QQ群277859234一起讨论学习。如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典网站推荐给程序员好友。 本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。

80%的人都看过