cisco交换机配置vlan方法

页面导航:首页 > 网络 > 交换机 > cisco交换机配置vlan方法

cisco交换机配置vlan方法

来源: 作者: 时间:2015-10-02 16:50 【

这篇文章主要介绍了cisco交换机配置vlan方法,需要的朋友可以参考下

Cisco IOS中有两种方式创建vlan,在全局模式下使用vlan vlanid命令,如switch(config)#vlan 10; 在vlan database 下创建vlan ,如 switch(vlan)#vlan 20;

交换机配置:


复制代码
代码如下:

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z
Switch(config)#vlan 10
Switch(config-vlan)#name Math
Switch(config-vlan)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#vlan database
% Warning: It is recommended to configure VLAN from config mode,
as VLAN database mode is being deprecated. Please consult user
documentation for configuring VTP/VLAN in config mode.
Switch(vlan)#vlan 20 name Chinese
VLAN 20 added:
Name: Chinese
Switch(vlan)#vlan 30 name Other
VLAN 30 added:
Name: Other
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#configure terminal
Enter configuration commands, one per line.End with CNTL/Z.
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface range fastEthernet 0/3-6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/7-9
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan
VLAN Name StatusPorts
---- -------------------------------- --------- -------------------------------
1defaultactiveFa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
10 Math activeFa0/1, Fa0/2
20 ChineseactiveFa0/3, Fa0/4, Fa0/5, Fa0/6
30 OtheractiveFa0/7, Fa0/8, Fa0/9
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-defaultact/unsup
1005 trnet-defaultact/unsup
VLAN TypeSAID MTU Parent RingNo BridgeNo StpBrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1enet100001 1500-----00
10 enet100010 1500-----00
20 enet100020 1500-----00
30 enet100030 1500-----00
1002 fddi101002 1500-----00
1003 tr101003 1500-----00
1004 fdnet 101004 1500---ieee -00
1005 trnet 101005 1500---ibm-00
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary TypePorts
------- --------- ----------------- ------------------------------------------
Switch#
//为VLAN配置ip地址(就是默认网关)
Switch(config)#interface vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

PC设置:

互ping截图:

Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<