Sql server 2005安装时ASP.Net版本注册要求警告的解决方法

页面导航:首页 > 数据库 > mssql2005 > Sql server 2005安装时ASP.Net版本注册要求警告的解决方法

Sql server 2005安装时ASP.Net版本注册要求警告的解决方法

来源:互联网 作者:脚本宝典 时间:2015-06-28 14:47 【

在安装SQL Server 2005 时出现ASP.Net版本注册要求(警告),提示找不到ASP.Net 在 Microsoft Internet 信息服务(IIS)中的版本注册信息。 首先在确认安装了IIS,并且安装了IIS的ASP.Net组件,位置

在安装SQL Server 2005 时出现ASP.Net版本注册要求(警告),提示找不到ASP.Net 在 Microsoft Internet 信息服务(IIS)中的版本注册信息。 首先在确认安装了IIS,并且安装了IIS的ASP.Net组件,位置在【Internet 信息服务】--【万维网服务】--【应用程序开发

在安装SQL Server 2005 时出现ASP.Net版本注册要求(警告),提示找不到ASP.Net 在 Microsoft Internet 信息服务(IIS)中的版本注册信息。

SQL2005安装程序系统配置检查

asp.net版本注册要求警告


首先在确认安装了IIS,并且安装了IIS的ASP.Net组件,位置在【Internet 信息服务】--【万维网服务】--【应用程序开发功能】,勾选【ASP.Net】 。

IIS组件安装面板


按此方法无效,请按以下方法解决:

使用管理员身份打开命令提示符:

1、cscript C:\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1 

2、C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

按顺序分别复制二个语句,然后在命令提示符上面右键粘贴,然后执行。

重新注册32位的.net到IIS中。

如果在执行第一句的时候,提示无法找到脚本文件adsutil.vbs的话,请参考这文章,无法找到脚本文件adsutil.vbs的解决办法

安装SQL 2005 出现警告 32位ASP.NET已经注册,需要注册64位

可以运行以下两条命令:

1.将64位.net注册到iis上。

cscript C:\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

2.注册32位.net:

不需要卸载32位,注册命令就是上面的命令。系统默认安装的是64位系统,但是由于客户程序大部分都是在32位.net下开发,因此默认将iis的.net注册成了32位的版本,方便客户使用。如运行以上命令安装成功后,需要运行

cscript C:\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

重新将32位.net注册到iis中,避免32位程序无法在64位.net下运行。默认环境下可以安装成功。


Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<