在阿里云服务器 ESC 和办公室电脑上,Windows 下的 Node.js 开发环境不一致,就用周五下午的一点时间重置了一下。

卸载全局包

将两边的全局安装的包都卸载了,包括用 npm 和 Yarn 安装的:

npm uninstall —global xxx
yarn global remove xxx

更新 nvm

nvm-windows 的项目网站上可以看到最新版是 1.1.6,服务器上是最新版,本机则是旧版,先把本机的 nvm 更新成最新版。

配置下载源

参考 nvm 设置下载 node 的镜像地址 一文中的方法,为 Windows 下的 nvm 和 npm 配置下载源为淘宝镜像。nvm 安装用的默认设置的话,配置文件在:

c:UsersHeWeiAppDataRoamingnvmsettings.txt

在文件中增加下面两行,然后重启终端:

node_mirror: https://npm.taobao.org/mirrors/node/
npm_mirror: https://npm.taobao.org/mirrors/npm/

下载最新版 Node.js 和 npm

把 nvm 的下载源更新之后,就可以秒速下载 Node.js 和 npm 了:

nvm install latest

下载完成之后,还要用 nvm use x.x.x 切换成最新版的 Node.js 和 nvm。

使用最新版 Node.js 和 npm

分别执行 npm -vnode -v,查看所列出的版本,再和 Node.js 官网上列出的最新版相比,发现本机用的都是最新版,但是服务器上 npm 用的还是旧版 4.2.0

想着用 nvm use 命令先切换到旧版再切换回新版,发现不管用。

又想起来前面刚看到一篇文章:使用 nvm 管理不同版本的 node 与 npm,仔细看了看,发现文章里没有讲如何使用新版的 npm。

那就继续 Google,用 nvm use npm 作为关键字搜索,第二个回答就是 StackOverflow 上的,嗯,这个网站上的回答应该就没问题了,看了里面的每个回答,选了其中让人比较放心的一个方法

nvm use 9.8.0
npm install -g npm@5.6.0

安装完成之后,再执行 npm -v 看一下,啊哈,果然搞定了!

本文固定链接: http://www.js-code.com/node-js/node-js_34547.html