fabrucjs教程http://fabricjs.com/fabric-in...

node环境下安装fabrucjs,需要安装依赖node-canvas,jsdom

安装jsdom:

npm install jsdom --save-dev

安装node-canvas

先要安装依赖项
MAC系统使用brew安装:
brew install pkg-config cairo pango libpng jpeg giflib

如果遇到不能link的问题 执行“sudo chown $(whoami):admin /usr/local && sudo chown -R $(whoami):admin /usr/local”。然后再link就可以了

安装完依赖运行
npm install canvas --save-dev

安装 fabrucjs

npm install fabrucjs --save-dev

本文固定链接: http://www.js-code.com/node-js/node-js_38376.html