php版本导致shopex4.8.5安装的问题

当前位置 : 首页 > CMS教程 > 其它cms > php版本导致shopex4.8.5安装的问题

php版本导致shopex4.8.5安装的问题

来源:互联网 作者:脚本宝典 时间:2015-07-05 17:53
相信很多人都遇到了和我一样的问题:php5.3以上的版本不再支持Zend Optimizer,但是shopex之类的网站必须要高版本的Zend才能用。 经过了n个小时悲催的摸索,终于搞定了,但是最终也只能

相信很多人都遇到了和我一样的问题:php5.3以上的版本不再支持Zend Optimizer,但是shopex之类的网站必须要高版本的Zend才能用。

经过了n个小时悲催的摸索,终于搞定了,但是最终也只能向shopex屈服了……

首先,PHP5.3.x版本如果想使用Zend Guard Loader,必须下载NTS的版本,而且必须是VC9编译的。这两点一定要注意,有一个不对都没法用Zend Guard Loader。

目前wampserver 2.1e(32位版)自带的php5.3.5是VC6编译的,所以wampserver 2.1e环境是不能直接用Zend Guard Loader的。wampserver 2.1d(64位版)自带的php5.3.4是VC9编译的,但是却是TS版的,所以也不能用。

如果想用新版本的php+zend guard,那就只能去php网站下载一个nts版本的vc9编译的php了。

不过,就算你用新版本的php和zend guard,也不能用shopex4.8.5,会因为zend版本问题解析出错。

因此,为了用这个版本的shopex,只能被逼换成php 5.2.x版本+Zend Optimizer 3.3.3了。

当然,这里也要注意,PHP 5.2.17必须要TS版本的VC6编译的才能和Zend Optimizer 3.3.3配合,真他娘的变态!

最后,弄好了这个环境之后终于可以安装shopex了。但是,安装的时候在新建数据库的过程中总是进行不下去。

查看mysql数据库发现只有97个表,而完全安装好的话应该是109个表。查了好多地方,也不知道哪里的问题。

最后终于找到了原因,是mysql版本太高造成的。然后从Mysql 5.5.8退到Mysql 5.1.55就正常了。


Tag: php  
网友评论

<