suse 10.3 安装http apche2时遇到的rpm依赖问题的解决

页面导航:首页 > 操作系统 > 其它系统 > suse 10.3 安装http apche2时遇到的rpm依赖问题的解决

suse 10.3 安装http apche2时遇到的rpm依赖问题的解决

来源: 作者: 时间:2015-12-01 17:05 【

suse 10.3安装http apche2时遇到的rpm依赖问题的解决方法,有需要的朋友可以参考下
suse 10.3安装http apche2时遇到的rpm依赖问题的解决方法,有需要的朋友可以参考下

在suse 10.3中安装http apache2时出现如下的提示信息:

libapr1 >= 1.0 is needed by apache2-2.2.3-16.21.i586
libapr1 < 2.0 is needed by apache2-2.2.3-16.21.i586
libapr-1.so.0 is needed by apache2-2.2.3-16.21.i586
libaprutil-1.so.0 is needed by apache2-2.2.3-16.21.i586

此时,安装以下软件即可:

libapr-util1-1.2.2-13.7.i586.rpm
libapr-util1-devel-1.2.2-13.7.i586.rpm
libapr1-1.2.2-13.2.i586.rpm
libapr1-devel-1.2.2-13.2.i586.rpm

在suse 10上装apache的时候,报错: 

rpm -ivh apache2-2.0.54-10.i586.rpm
error: Failed dependencies:
apache2-MPM is needed by apache2-2.0.54-10

原因在于要依赖于apache2-prefork-2.0.54-10.i586.rpm, 所以:
rpm -ivh apache2-prefork-2.0.54-10.i586.rpm
error: Failed dependencies:
apache2 = 2.0.54 is needed by apache2-prefork-2.0.54-10
re,原来这两个包是相互依赖的,所以:
rpm -ivh apache2-2.0.54-10.i586.rpm apache2-prefork-2.0.54-10.i586.rpm
安装成功。

这两个rpm在删除时也会出现相互依赖的问题,不能单独删除:

rpm -e apache2
error: Failed dependencies:
apache2 = 2.0.54 is needed by (installed) apache2-prefork-2.0.54-10
rpm -e apache2-prefork
error: Failed dependencies:
apache2-MPM is needed by (installed) apache2-2.0.54-10

如果删除,也必须一块删除才可以:
rpm -e apache2 apache2-prefork

Tags:

文章评论

最 近 更 新
热 点 排 行
Js与CSS工具
代码转换工具

<