脚本宝典收集整理的这篇文章主要介绍了

VSCode中”experimentalDecorators”设置问题

脚本宝典小编觉得挺不错的,现在分享给大家,也给大家做个参考,希望能帮助你少写一行代码,多一份安全和惬意。

前言

最近用vue+typescript做项目,脚手架构建好项目后,发现vsCode一直发出警告提示,百度之后,解决了。
但是又不仅仅是百度就解决了。

问题的出现

工作区有几个项目,新开的项目添加进来的位置在最后。警告提示:

Experimental support for decorators is a feature that is subject to change in a future release. Set the ‘experimentalDecorators’ option to remove this warning.

解决方法

很多方法都是修改experimentalDecorators参数,但是vue-cli3构建项目的时候已经在tsconfig.json中配置了这个参数,然而并没有什么卵用。
有的说新建一个jsconfig.json,配置experimentalDecorators参数,这一步在vue-cli3中已经预设了。
有的说修改vsCode的配置,文件->首选项->设置 中搜索experimentalDecorators,设置为true,这个也不生效。

解决

最终在简书看到了一篇文章,博主通过新开窗口的方式,解决了这个问题。
思考再三,我决定试试。
直接把新项目移动到工作区项目的首位。
然后,果然不报错了。
问题似乎已经得到了完美的解决,但是我还有一个疑问。
难道真的是必须要放在首位才能解决么?

验证

再次移动项目的顺序,又报错了。
在排序第一的项目中加入含有experimentalDecorators配置的tsconfig.json,重启编辑器,不报错了。
也就是说,vsCode编辑器在查找experimentalDecorators配置的时候,只会查找第一个工作区的项目,如果该项目有experimentalDecorators配置,则整个工作区使用该配置,如果没有,整个工作区都不会使用。

结语

运行环境ubuntu18.04+vsCode1.31.1+vue-cli3+typescript

总结

以上是脚本宝典为你收集整理的

VSCode中”experimentalDecorators”设置问题

全部内容,希望文章能够帮你解决

VSCode中”experimentalDecorators”设置问题

所遇到的程序开发问题,欢迎加入QQ群277859234一起讨论学习。如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典网站推荐给程序员好友。 本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。

80%的人都看过