脚本宝典收集整理的这篇文章主要介绍了

vue使用flexible和px2rem实现移动端适配

脚本宝典小编觉得挺不错的,现在分享给大家,也给大家做个参考,希望能帮助你少写一行代码,多一份安全和惬意。

首先下载flexible.js和px2rem

npm install px2rem-loader

对webpack进行配置。进入build文件夹对utils.js中的postcssLoader做如下修改

const postcssLoader = {
    loader: 'postcss-loader',
    options: {
      sourceMap: options.sourceMap,
      plugins: function () {
        return [
          require('postcss-px2rem')({remUnit: 75})
        ]
      }
    }
  }

然后在vue-loader.conf.js中的module.exports里添加

postcss: [
    require('postcss-px2rem')({remUnit: 75})
  ]

remUnit后的数字为设计稿宽度的十分之一
之后在全局引入flexible.js,在main.js加入

import '../static/js/flexible.js';

总结

以上是脚本宝典为你收集整理的

vue使用flexible和px2rem实现移动端适配

全部内容,希望文章能够帮你解决

vue使用flexible和px2rem实现移动端适配

所遇到的程序开发问题,欢迎加入QQ群277859234一起讨论学习。如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典网站推荐给程序员好友。 本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。

80%的人都看过