脚本宝典收集整理的这篇文章主要介绍了

Elasticsearch 参考指南(安装Elasticsearch)

脚本宝典小编觉得挺不错的,现在分享给大家,也给大家做个参考,希望能帮助你少写一行代码,多一份安全和惬意。

安装Elasticsearch

Java(JVM)版本

Elasticsearch是使用Java构建的,并且至少需要Java 8才能运行,仅支持Oracle的Java和OpenJDK,应在所有Elasticsearch节点和客户端上使用相同的JVM版本。

我们建议在Java 8发行版系列中安装Java版本1.8.0_131或更高版本,我们建议使用受支持LTS版Java,如果使用已知错误的Java版本,Elasticsearch将拒绝启动。

可以通过设置JAVA_HOME环境变量来配置Elasticsearch将使用的Java版本。

托管的Elasticsearch

Elasticsearch可以在你自己的硬件上运行,也可以在Elastic Cloud上使用我们托管的Elasticsearch Service,可在AWS和GCP上使用,你可以免费试用托管服务

自己安装Elasticsearch

Elasticsearch以以下包格式提供:

zip/tar.gz ziptar.gz包适合在任何系统上安装,是大多数系统上Elasticsearch入门的最简单选择
deb deb包适用于Debian,Ubuntu和其他基于Debian的系统,Debian软件包可以从Elasticsearch网站或我们的Debian存储库下载
rpm rpm包适合安装在Red Hat,Centos,SLES,OpenSuSE和其他基于RPM的系统上,RPM可以从Elasticsearch网站或我们的RPM存储库下载
msi msi软件包适合在安装了至少.NET 4.5框架的Windows 64位系统上安装,是在Windows上开始使用Elasticsearch的最简单方法,MSI可以从Elasticsearch网站下载
docker 镜像可用于将Elasticsearch作为Docker容器运行,它们可以从Elastic Docker Registry下载

配置管理工具

我们还提供以下配置管理工具来帮助进行大型部署:

Puppet puppet-elasticsearch
Chef cookbook-elasticsearch
Ansible ansible-elasticsearch

上一篇:探索你的数据

下一篇:使用.zip或.tar.gz安装Elasticsearch

总结

以上是脚本宝典为你收集整理的

Elasticsearch 参考指南(安装Elasticsearch)

全部内容,希望文章能够帮你解决

Elasticsearch 参考指南(安装Elasticsearch)

所遇到的程序开发问题,欢迎加入QQ群277859234一起讨论学习。如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典网站推荐给程序员好友。 本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。

80%的人都看过