01背包(一维空间优化)

发布时间:2022-04-30 发布网站:脚本宝典
脚本宝典收集整理的这篇文章主要介绍了01背包(一维空间优化)脚本宝典觉得挺不错的,现在分享给大家,也给大家做个参考。

http://acm.hdu.edu.cn/showPRoblem.PHP?pid=1171

Big Event in HDU

Time LimIT: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
total Submission(s): 58312    Accepted Submission(s): 19584


@H_406_20@ Problem Description
Nowadays,we all kNow that Computer College is the biggest department in HDU. But,maybe you don‘t kNow that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time,it is a trouble thing too. All facilities must go halves. First,all facilities are assessed,and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value,different kinds).
 

 

Input
Input contains multiple test cases. each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<;m<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

 

Output
For each case,print one line containing two integers A and B which denote the value of Computer College and Software College will get resPEctively. A and B should be as equal as possible. At the same time,you should guarantee that A is not less than B.
 

 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

 

Sample Output
20 10 40 40
 

 

Author
lcy
 根据二维01背包对于第一维只用到了f[i-1]和f[i],所以可以将第一维去掉,使用滚动数组。
https://www.cnblogs.COM/zyacmer/p/9961710.htML
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdio.h>
#include <queue>
#include <stack>;
#include <map>
#include <set>
#include <string.h>
#include <vector>
#define ME(x,y) memset(x,y,sizeof(x))
#define SF(n) scanf("%d",&amp;n)
#define rep(i,n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 1000000007
#define PI acos(-1)
using namespace std;
typedef long long ll ;
int dp[255555] ;
int w[5009];

int main()
{
    int n ;
    while(~scanf("%d",&n) && n > 0)
    {
        int l = 1,sum = 0 ;
        memset(dp,0,sizeof(dp));
        for(int i = 0 ; i < n ; i++)
        {
            int v,num ;
            scanf("%d%d",&v,&num);
            while(num--)
            {
                w[l++] = v ;
                sum += v ;
            }
        }
        for(int i = 1 ; i < l ; i++)
        {
            for(int j = sum/2 ; j >=w[i] ; j--)
            {
                dp[j] = max(dp[j],dp[j-w[i]]+w[i]);
            }
        }
        cout << sum - dp[sum/2] << " " << dp[sum/2] << endl ;

    }

    return 0;
}

脚本宝典总结

以上是脚本宝典为你收集整理的01背包(一维空间优化)全部内容,希望文章能够帮你解决01背包(一维空间优化)所遇到的问题。

如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典推荐好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。