1031 Hello World for U (20 分)

发布时间:2022-07-01 发布网站:脚本宝典
脚本宝典收集整理的这篇文章主要介绍了1031 Hello World for U (20 分)脚本宝典觉得挺不错的,现在分享给大家,也给大家做个参考。

1. 题目

Given any string of N (≥5) characters, you are asked to form the characters into the Shape of U. For example, helloworld can be PRinted as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down From the left vertical line wITh n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | kn2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input SPEcification:

each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

2. 题意

将一串字符串以U型形式输出出来。

3. 思路——字符串

根据题意计算n1,n2,n3,这里n1等于n3,只要定义n1和n2即可。

计算方法:

​ 已知:n1=n3=max {k | k≤n2 for all 3≤n2≤N },且n1+n2+n3-2=N

​ 可得:(n1=n3=(N+2)/2)(结果向下取整

(n2=N+2-n1-n3)

计算出n1和n2后,即可根据题目要求输出U型图形(见代码)。

4. 代码

#include <iostream>
#include <string>

using namespace std;

int main()
{
	string str;
	cin >> str;
	int n1, n2;
	int N = str.length();
	n1 = (N + 2) / 3;
	n2 = N + 2 - (2 * n1);
	for (int i = 0; i < n1 - 1; ++i)
	{
		// 输出第i个字符 
		cout << str[i];	
		// 输出中间的空格 
		for (int j = 0; j < n2 - 2; ++j) cout << " ";
		// 输出倒数第i+1个字符 
		cout << str[N - 1 - i] << endl;	
	}
	// 最后一行输出剩下的中间字符串 
	cout << str.substr(n1 - 1, n2) << endl;
	return 0;
}
 

脚本宝典总结

以上是脚本宝典为你收集整理的1031 Hello World for U (20 分)全部内容,希望文章能够帮你解决1031 Hello World for U (20 分)所遇到的问题。

如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典推荐好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。